Delayed Processing of Incoming Bank Transfer Notifications

Incident Report for Algbra

Resolved

This incident has been resolved.
Posted May 11, 2026 - 09:51 BST

Identified

We are aware of an issue affecting incoming bank transfer processing. Some inbound transfers may temporarily appear as cancelled or delayed before being processed successfully. Payments are not failing, but transaction visibility and processing may be delayed while we work to fully resolve the issue.
Posted May 08, 2026 - 13:30 BST
This incident affected: Algbra UK (Bank Transfers) and Shoal UK (Bank Transfers).