A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2024 - 17:55 GMT
Investigating
We are aware of multiple repeated card payments from June on some customers. Teams are investigating this with card scheme, further updates will be shared.
Posted Nov 18, 2024 - 11:02 GMT
This incident affected: Algbra UK (Card Payments).