Bank Payment Issues
Incident Report for Algbra
Resolved
All issues now resolved.
Posted Nov 10, 2024 - 09:58 GMT
Monitoring
Issue has been fixed, our teams monitoring the changes.
Posted Nov 10, 2024 - 09:21 GMT
Identified
We have identified the issue and working on it.
Posted Nov 10, 2024 - 06:12 GMT
This incident affected: Algbra UK (Bank Transfers).